use strict;
my $str = 'Fri, 20 Apr 2012 12:00:00 EST';
my $regex = qr/[a-zA-Z]{3}, ([0-9]{1,2}) ([a-zA-Z]{3}) ([0-9]{4}) [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{3}/p;
my $subst = '\\2 \\1, \\3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";