$re = '/[a-zA-Z]{3}, ([0-9]{1,2}) ([a-zA-Z]{3}) ([0-9]{4}) [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{3}/';
$str = 'Fri, 20 Apr 2012 12:00:00 EST';
$subst = "\2 \1, \3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;