// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-zA-Z]{3}, ([0-9]{1,2}) ([a-zA-Z]{3}) ([0-9]{4}) [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{3}").unwrap();
let string = "Fri, 20 Apr 2012 12:00:00 EST";
let substitution = "\\2 \\1, \\3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}