import Foundation
let pattern = #"[a-zA-Z]{3}, ([0-9]{1,2}) ([a-zA-Z]{3}) ([0-9]{4}) [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Fri, 20 Apr 2012 12:00:00 EST"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2 \1, \3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}