import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]{3}, ([0-9]{1,2}) ([a-zA-Z]{3}) ([0-9]{4}) [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{3}";
final String string = "Fri, 20 Apr 2012 12:00:00 EST";
final String subst = "\\2 \\1, \\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}