#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\b|_)(?<TrackNumber>\d{3})(?=\b|_)"
Local $sString = "ISBN_9781338034424_001_S_r1.mp3" & @CRLF & _
"001_Ch001_987373737.mp3" & @CRLF & _
"This Is test 001 Chap01.mp3" & @CRLF & _
"Anger_Cha01_001.mp3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")