const regex = /(?<=\b|_)(?<TrackNumber>\d{3})(?=\b|_)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\b|_)(?<TrackNumber>\\d{3})(?=\\b|_)', 'g')
const str = `ISBN_9781338034424_001_S_r1.mp3
001_Ch001_987373737.mp3
This Is test 001 Chap01.mp3
Anger_Cha01_001.mp3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}