import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\b|_)(?<TrackNumber>\\d{3})(?=\\b|_)";
final String string = "ISBN_9781338034424_001_S_r1.mp3\n"
+ "001_Ch001_987373737.mp3\n"
+ "This Is test 001 Chap01.mp3\n"
+ "Anger_Cha01_001.mp3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}