use strict;
my $str = 'ISBN_9781338034424_001_S_r1.mp3
001_Ch001_987373737.mp3
This Is test 001 Chap01.mp3
Anger_Cha01_001.mp3';
my $regex = qr/(?<=\b|_)(?<TrackNumber>\d{3})(?=\b|_)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}