import re
regex = re.compile(r"(?<=\b|_)(?<TrackNumber>\d{3})(?=\b|_)")
test_str = ("ISBN_9781338034424_001_S_r1.mp3\n"
"001_Ch001_987373737.mp3\n"
"This Is test 001 Chap01.mp3\n"
"Anger_Cha01_001.mp3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")