import Foundation
let pattern = #"(?<=\b|_)(?<TrackNumber>\d{3})(?=\b|_)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ISBN_9781338034424_001_S_r1.mp3
001_Ch001_987373737.mp3
This Is test 001 Chap01.mp3
Anger_Cha01_001.mp3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)