using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\b|_)(?<TrackNumber>\d{3})(?=\b|_)";
string input = @"ISBN_9781338034424_001_S_r1.mp3
001_Ch001_987373737.mp3
This Is test 001 Chap01.mp3
Anger_Cha01_001.mp3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}