$re = '/(?<=\b|_)(?<TrackNumber>\d{3})(?=\b|_)/';
$str = 'ISBN_9781338034424_001_S_r1.mp3
001_Ch001_987373737.mp3
This Is test 001 Chap01.mp3
Anger_Cha01_001.mp3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);