package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/^([a-z0-9]+(?:,[a-z0-9]+)*)$/gm`)
var str = `khjh,sdsds,sdsdsd,22222,22222;@@@;222-2-222;`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}