import Foundation
let pattern = #"/^([a-z0-9]+(?:,[a-z0-9]+)*)$/gm"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"khjh,sdsds,sdsdsd,22222,22222;@@@;222-2-222;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}