$re = '//^([a-z0-9]+(?:,[a-z0-9]+)*)$/gm/';
$str = 'khjh,sdsds,sdsdsd,22222,22222;@@@;222-2-222;';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);