re = /\/^([a-z0-9]+(?:,[a-z0-9]+)*)$\/gm/
str = 'khjh,sdsds,sdsdsd,22222,22222;@@@;222-2-222;'
# Print the match result
str.match(re) do |match|
puts match.to_s
end