# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<var( [^=]*="[^"]*")*>(\d+)<\\/var>/[[[$2]]]/gi;t' <<< "<var id-0=\"\" link=\"adx\"></var> responds <span id-1=\"\">in <var id=\"gdsa\" num=\"vs\">1</var> days</span>"