import Foundation
let pattern = #"<var( [^=]*="[^"]*")*>(\d+)<\/var>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<var id-0="" link="adx"></var> responds <span id-1="">in <var id="gdsa" num="vs">1</var> days</span>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[[[$2]]]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)