const regex = /<var( [^=]*="[^"]*")*>(\d+)<\/var>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<var( [^=]*="[^"]*")*>(\\d+)<\\\/var>', 'gi')
const str = `<var id-0="" link="adx"></var> responds <span id-1="">in <var id="gdsa" num="vs">1</var> days</span>`;
const subst = `[[[$2]]]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);