package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<var( [^=]*="[^"]*")*>(\d+)<\/var>`)
var str = `<var id-0="" link="adx"></var> responds <span id-1="">in <var id="gdsa" num="vs">1</var> days</span>`
var substitution = "[[[$2]]]"
fmt.Println(re.ReplaceAllString(str, substitution))
}