using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<var( [^=]*=""[^""]*"")*>(\d+)<\/var>";
string substitution = @"[[[$2]]]";
string input = @"<var id-0="" link=""adx""></var> responds <span id-1="">in <var id=""gdsa"" num=""vs"">1</var> days</span>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}