use strict;
my $str = '<var id-0="" link="adx"></var> responds <span id-1="">in <var id="gdsa" num="vs">1</var> days</span>';
my $regex = qr/<var( [^=]*="[^"]*")*>(\d+)<\/var>/ip;
my $subst = '[[[$2]]]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";