re = /<var( [^=]*="[^"]*")*>(\d+)<\/var>/i
str = '<var id-0="" link="adx"></var> responds <span id-1="">in <var id="gdsa" num="vs">1</var> days</span>'
subst = '[[[$2]]]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result