#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a\s[^>]*>"
Local $sString = "<a href>" & @CRLF & _
"<a href="www.example.com">" & @CRLF & _
"<a href="http://www.google.com" target="_blank">click me</a>" & @CRLF & _
"<a href="www.google.com" > click me</a>" & @CRLF & _
"<A href="www.123-xyz.com" > click me</a>" & @CRLF & _
"<a href="www.google.com" target="_blank"> www.google.com</a><a href="www.google.com" >click me</a>" & @CRLF & _
"<a href="www.google.com" target="_blank"> www.google.com</a>" & @CRLF & _
"<a href="www.google.com" >click me</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")