use strict;
my $str = '<a href>
<a href="www.example.com">
<a href="http://www.google.com" target="_blank">click me</a>
<a href="www.google.com" > click me</a>
<A href="www.123-xyz.com" > click me</a>
<a href="www.google.com" target="_blank"> www.google.com</a><a href="www.google.com" >click me</a>
<a href="www.google.com" target="_blank"> www.google.com</a>
<a href="www.google.com" >click me</a>';
my $regex = qr/<a\s[^>]*>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}