import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s[^>]*>";
final String string = "<a href>\n"
+ "<a href=\"www.example.com\">\n"
+ "<a href=\"http://www.google.com\" target=\"_blank\">click me</a>\n"
+ "<a href=\"www.google.com\" > click me</a>\n"
+ "<A href=\"www.123-xyz.com\" > click me</a>\n"
+ "<a href=\"www.google.com\" target=\"_blank\"> www.google.com</a><a href=\"www.google.com\" >click me</a>\n"
+ "<a href=\"www.google.com\" target=\"_blank\"> www.google.com</a>\n"
+ "<a href=\"www.google.com\" >click me</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}