// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<a\s[^>]*>").unwrap();
let string = "<a href>
<a href=\"www.example.com\">
<a href=\"http://www.google.com\" target=\"_blank\">click me</a>
<a href=\"www.google.com\" > click me</a>
<A href=\"www.123-xyz.com\" > click me</a>
<a href=\"www.google.com\" target=\"_blank\"> www.google.com</a><a href=\"www.google.com\" >click me</a>
<a href=\"www.google.com\" target=\"_blank\"> www.google.com</a>
<a href=\"www.google.com\" >click me</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}