const regex = /<a\s[^>]*>/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s[^>]*>', 'ig')
const str = `<a href>
<a href="www.example.com">
<a href="http://www.google.com" target="_blank">click me</a>
<a href="www.google.com" > click me</a>
<A href="www.123-xyz.com" > click me</a>
<a href="www.google.com" target="_blank"> www.google.com</a><a href="www.google.com" >click me</a>
<a href="www.google.com" target="_blank"> www.google.com</a>
<a href="www.google.com" >click me</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}