package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<a\s[^>]*>`)
var str = `<a href>
<a href="www.example.com">
<a href="http://www.google.com" target="_blank">click me</a>
<a href="www.google.com" > click me</a>
<A href="www.123-xyz.com" > click me</a>
<a href="www.google.com" target="_blank"> www.google.com</a><a href="www.google.com" >click me</a>
<a href="www.google.com" target="_blank"> www.google.com</a>
<a href="www.google.com" >click me</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}