using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s[^>]*>";
string input = @"<a href>
<a href=""www.example.com"">
<a href=""http://www.google.com"" target=""_blank"">click me</a>
<a href=""www.google.com"" > click me</a>
<A href=""www.123-xyz.com"" > click me</a>
<a href=""www.google.com"" target=""_blank""> www.google.com</a><a href=""www.google.com"" >click me</a>
<a href=""www.google.com"" target=""_blank""> www.google.com</a>
<a href=""www.google.com"" >click me</a>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}