re = /<a\s[^>]*>/i
str = '<a href>
<a href="www.example.com">
<a href="http://www.google.com" target="_blank">click me</a>
<a href="www.google.com" > click me</a>
<A href="www.123-xyz.com" > click me</a>
<a href="www.google.com" target="_blank"> www.google.com</a><a href="www.google.com" >click me</a>
<a href="www.google.com" target="_blank"> www.google.com</a>
<a href="www.google.com" >click me</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end