#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\b[A-Z][a-z]*(\s*\b[A-Z][a-z]*\b)*$"
Local $sString = "Naveen Kumar" & @CRLF & _
"Naveen kumar" & @CRLF & _
"naveen Kumar" & @CRLF & _
"Avinash_Raj Raj" & @CRLF & _
"Avinash_Raj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")