re = /^\b[A-Z][a-z]*(\s*\b[A-Z][a-z]*\b)*$/m
str = 'Naveen Kumar
Naveen kumar
naveen Kumar
Avinash_Raj Raj
Avinash_Raj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end