package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\b[A-Z][a-z]*(\s*\b[A-Z][a-z]*\b)*$`)
var str = `Naveen Kumar
Naveen kumar
naveen Kumar
Avinash_Raj Raj
Avinash_Raj`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}