use strict;
my $str = 'Naveen Kumar
Naveen kumar
naveen Kumar
Avinash_Raj Raj
Avinash_Raj';
my $regex = qr/^\b[A-Z][a-z]*(\s*\b[A-Z][a-z]*\b)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}