const regex = /^\b[A-Z][a-z]*(\s*\b[A-Z][a-z]*\b)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\b[A-Z][a-z]*(\\s*\\b[A-Z][a-z]*\\b)*$', 'gm')
const str = `Naveen Kumar
Naveen kumar
naveen Kumar
Avinash_Raj Raj
Avinash_Raj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}