$re = '/^\b[A-Z][a-z]*(\s*\b[A-Z][a-z]*\b)*$/m';
$str = 'Naveen Kumar
Naveen kumar
naveen Kumar
Avinash_Raj Raj
Avinash_Raj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);