import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\b[A-Z][a-z]*(\\s*\\b[A-Z][a-z]*\\b)*$";
final String string = "Naveen Kumar\n"
+ "Naveen kumar\n"
+ "naveen Kumar\n"
+ "Avinash_Raj Raj\n"
+ "Avinash_Raj";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}