// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\b[A-Z][a-z]*(\s*\b[A-Z][a-z]*\b)*$").unwrap();
let string = "Naveen Kumar
Naveen kumar
naveen Kumar
Avinash_Raj Raj
Avinash_Raj";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}