# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(i|b).+>(.+)<\\/(i|b)>/<$1>$2<\/$3>/g;t' <<< "<i style=I>asd</i>
<i style=I>asd</i>
<i style=I>asd</i>"