$re = '/<(i|b).+>(.+)<\/(i|b)>/';
$str = '<i style=I>asd</i>
<i style=I>asd</i>
<i style=I>asd</i>';
$subst = "<$1>$2</$3>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;