const regex = /<(i|b).+>(.+)<\/(i|b)>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(i|b).+>(.+)<\\\/(i|b)>', 'g')
const str = `<i style=I>asd</i>
<i style=I>asd</i>
<i style=I>asd</i>`;
const subst = `<$1>$2</$3>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);