use strict;
my $str = '<i style=I>asd</i>
<i style=I>asd</i>
<i style=I>asd</i>';
my $regex = qr/<(i|b).+>(.+)<\/(i|b)>/p;
my $subst = '<$1>$2</$3>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";