using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(i|b).+>(.+)<\/(i|b)>";
string substitution = @"<$1>$2</$3>";
string input = @"<i style=I>asd</i>
<i style=I>asd</i>
<i style=I>asd</i>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}