import re
regex = re.compile(r"<(i|b).+>(.+)<\/(i|b)>")
test_str = ("<i style=I>asd</i>\n"
"<i style=I>asd</i>\n"
"<i style=I>asd</i>")
subst = "<$1>$2</$3>"
result = regex.sub(subst, test_str)
if result:
print(result)