# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$\\\w*{[^}]+}(*SKIP)(*F)|{[^}]*}//gm;t' <<< "Lorem Ipsum $\mathbb{R}$ dolore. {Author} $\{1,\dotsc,n}$
$\mathbb{R} $ dolore. {Author}"