import Foundation
let pattern = #"\$\\\w*{[^}]+}(*SKIP)(*F)|{[^}]*}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lorem Ipsum $\mathbb{R}$ dolore. {Author} $\{1,\dotsc,n}$
$\mathbb{R} $ dolore. {Author}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)