#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\$\\\w*{[^}]+}(*SKIP)(*F)|{[^}]*}"
Local $sString = "Lorem Ipsum $\mathbb{R}$ dolore. {Author} $\{1,\dotsc,n}$" & @CRLF & _
"$\mathbb{R} $ dolore. {Author}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)