using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\\\w*{[^}]+}(*SKIP)(*F)|{[^}]*}";
string substitution = @"";
string input = @"Lorem Ipsum $\mathbb{R}$ dolore. {Author} $\{1,\dotsc,n}$
$\mathbb{R} $ dolore. {Author}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}